CPUG: The Check Point User Group

Resources for the Check Point Community, by the Check Point Community.


First, I hope you're all well and staying safe.
Second, I want to give a "heads up" that you should see more activity here shortly, and maybe a few cosmetic changes.
I'll post more details to the "Announcements" forum soon, so be on the lookout. -E

 

Results 1 to 3 of 3

Thread: Installation failed. Reason: Load on module failed - no memory

  1. #1
    Join Date
    2017-09-20
    Posts
    1
    Rep Power
    0

    Default Installation failed. Reason: Load on module failed - no memory

    Tried to Implementing a change but getting error (Installation failed. Reason: Load on module failed - no memory). Checked the logs and found high CPU errors, but blades didn't show an abnormal load.

    I reboot the blade 1_1 using 'asg_reboot -b 1_1' . Issue got resolved. But temporary.

    Please advice with your suggestions

    Sent from my SM-G930F using Tapatalk

  2. #2
    Join Date
    2009-04-30
    Location
    Colorado, USA
    Posts
    2,252
    Rep Power
    15

    Default Re: Installation failed. Reason: Load on module failed - no memory

    Quote Originally Posted by amandeep.dhiman9 View Post
    Tried to Implementing a change but getting error (Installation failed. Reason: Load on module failed - no memory). Checked the logs and found high CPU errors, but blades didn't show an abnormal load.

    I reboot the blade 1_1 using 'asg_reboot -b 1_1' . Issue got resolved. But temporary.

    Please advice with your suggestions

    Sent from my SM-G930F using Tapatalk
    This is a rather generic error message indicating that the firewall could not complete the atomic load of the policy into the kernel for some reason. It could be due to lack of memory on the gateway, but not always. The list of possible causes is rather long, you'll need to go through sk101875: Policy installation fails with "Load on module failed - no memory" error .
    --
    Third Edition of my "Max Power 2020" Firewall Book
    Now Available at http://www.maxpowerfirewalls.com

  3. #3
    Join Date
    2008-07-31
    Location
    Netherlands, Europe
    Posts
    1,147
    Rep Power
    14

    Default Re: Installation failed. Reason: Load on module failed - no memory

    We see this quite often, mostly on reasonably busy firewalls, when we do the install during low traffic moments, it mostly finishes just fine, otherwise check the uptime, when the firewall is pushed on a daily basis it will be happening more than with a gateway that is pushed once a month.
    Other point we have noticed with this, the more blades are enabled the quicker it happens. We have firewalls with only IPS enabled that never gives this error, we also have firewalls with all NGTP blades enabled and there we see this issue quite often.

    Longer uptime can also cause the issue and rebooting the gateway will resolve the issue. When you need to do so also look at installing the latest Jumbo.
    Regards, Maarten.
    Triple MDS on R77.30, MDS on R80.10, VSX, GAIA.

Similar Threads

  1. Installation failed. Reason: Load on Module failed - failed to load Security Policy.
    By DannyW in forum Security Management Server (Formerly SmartCenter Server ((Formerly Management Server))
    Replies: 2
    Last Post: 2015-11-11, 14:23
  2. Replies: 2
    Last Post: 2012-11-30, 03:37
  3. Replies: 0
    Last Post: 2012-11-16, 07:15
  4. Installation Failed. Reason: Failed to Load Policy on Module. (Message from member)
    By rdbalaji in forum Security Management Server (Formerly SmartCenter Server ((Formerly Management Server))
    Replies: 2
    Last Post: 2012-11-15, 04:20
  5. Replies: 3
    Last Post: 2011-09-20, 09:58

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •