CPUG: The Check Point User Group

Resources for the Check Point Community, by the Check Point Community.


First, I hope you're all well and staying safe.
Second, I want to give a "heads up" that you should see more activity here shortly, and maybe a few cosmetic changes.
I'll post more details to the "Announcements" forum soon, so be on the lookout. -E

 

Results 1 to 7 of 7

Thread: SmartCenter NGX R62 Install on Solaris 10

  1. #1
    Join Date
    2009-04-27
    Posts
    11
    Rep Power
    0

    Default SmartCenter NGX R62 Install on Solaris 10

    Hi Everyone,

    I have installed SmartCenter on a Solaris 10 Server but it is not recognizing any Checkpoint commands such as cpstart, cpstop, cpinfo, etc. I do not have a lot of experience with Unix so any help would be appreciated.

  2. #2
    Join Date
    2006-07-28
    Location
    San Francisco, USA
    Posts
    2,494
    Rep Power
    16

    Default Re: SmartCenter NGX R62 Install on Solaris 10

    Not sure what shell you're using, but try running:
    . /opt/CPshrd-R62/tmp/.CPprofile.sh

    That should set your environment right. That should also be run when you login as root. Check what root has in .profile. Also make sure that you are running "sudo su -" (the last - is important, to ensure you get the full environment).

  3. #3
    Join Date
    2009-04-27
    Posts
    11
    Rep Power
    0

    Default Re: SmartCenter NGX R62 Install on Solaris 10

    I tried to run the command but received an error stating the file does not exist. I then CD'd over to /opt/CPshrd-R62/tmp/ to see if the .CPprofile.sh did exist, but it does not. The default shell is pkfsh but I usually use bash. I have already tried removing the CP packages and reinstalling them but am having the same problem. Is it advisable to modify the root profile to add the path or correct variables and if so how do I do it as I do not have a lot of experience with Unix?

  4. #4
    Join Date
    2006-04-27
    Location
    Twillight zone
    Posts
    1,010
    Rep Power
    16

    Default Re: SmartCenter NGX R62 Install on Solaris 10

    Perhaps dumb question, but after actual installation of smartcenter did you go through initial configuration using cpconfig command? If not, do that, then logout/login.

  5. #5
    Join Date
    2009-04-27
    Posts
    11
    Rep Power
    0

    Default Re: SmartCenter NGX R62 Install on Solaris 10

    Yes, I had initially tried that but the problem is that it does not recognize any of the CP commands.

  6. #6
    Join Date
    2007-07-16
    Location
    a land down under!
    Posts
    2,015
    Rep Power
    15

    Default Re: SmartCenter NGX R62 Install on Solaris 10

    Were you logged in as root when you did the original install?

  7. #7
    Join Date
    2009-04-27
    Posts
    11
    Rep Power
    0

    Default Re: SmartCenter NGX R62 Install on Solaris 10

    Yes, I had sudo 'd over to root via sudo su -. Anyhow, I copied the .profile for root over from the primary CP Server which has resolved the issue. Thank you to everyone for all of your advice.

Similar Threads

  1. Install R65 on T200 -(Solaris 10) Fail!!
    By pviana in forum Sun Solaris
    Replies: 0
    Last Post: 2008-10-20, 08:06
  2. Where & how to install upgrade_export on Solaris 8
    By ddarby1 in forum Sun Solaris
    Replies: 3
    Last Post: 2008-02-25, 04:59
  3. Install Smartcenter R61 on solaris
    By antonyso88 in forum Installing And Upgrading
    Replies: 5
    Last Post: 2007-01-23, 21:10
  4. How to install NGX on Solaris
    By Yasushi Kono in forum Installing And Upgrading
    Replies: 2
    Last Post: 2006-11-01, 18:30
  5. Install Errors on Solaris 10 and NGX
    By clubnbabyseals in forum Installing And Upgrading
    Replies: 3
    Last Post: 2006-07-18, 22:16

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •