PDA

View Full Version : Problems with R65 gui client in read-only mode



res002mg
2007-06-25, 14:50
Hello,
Last week upgraded SmartCenter and SmartLog servers to R65.
After an upgrade Administrators with Read-Only rights cannot save log-filters.
Thank you in advance for any help.

melipla
2007-06-25, 18:32
I thought log-filters were saved on the machine where Smartdashboard was installed at? I get prompted to "import" them when I install a newer version of smartdashboard....in which case isn't it a problem with saving them locally to the workstation?

Or are you referring to saving a filtered logfile to the smartcenter?

res002mg
2007-06-27, 10:17
You are correct it asked me to import also, which works. I tested with my id ( i have R/W) right to SmartCenter and Log servers). When I am in R/W I can save filters. If I login with R only I cannot save filters. Error: database is read only. I agree with you that filters 'should' be saved on local machine?

melipla
2007-06-27, 14:20
I agree with you that filters 'should' be saved on local machine?

Yes, that was my assumption. I tried searching but was unable to find my custom filters. I will say that I've never had much luck "importing" them from previous versions, enough trouble that I find that its easier to recreate the ones I have by hand. Some day when I have more then 5 custom filters that may be an issue ...

res002mg
2007-06-28, 15:39
Going back to original question: I checked rights on the directory where SmarConsole is installed to make sure there is no issue with directory permissions (I have full control over the directory, subdirectories and files). I also played with permission profiles for R/only admins in SmartDashboard (gave R/W access to logs) but still no luck with saving queuries with read only permissions. I also checked tracker log for any drops or out of sync packets, no abnormal entries. Any ideas? Does anyone else has similar problem?

res002mg
2007-07-02, 11:02
Hi, this is answer directly from Checkpoint:
This behavior indeed changed from R60, because on R65 the SmartView Tracker keeps the queries on the SmartCenter database and not on the local GUI machine, hence the permissions issue. One of the benefits of this feature is to allow you to have access to your custom queries from any GUI machine.