PDA

View Full Version : TCP Connectivity Failure (Port =18191) Error No. 10



roadrunner
2005-08-13, 15:20
TCP connectivity failure (port =18191) error no. 10
I am facing huge troubles with SecurePlatform Application Intelligence. Independent of the hardware configuration, the firewall node absorbs huge amounts of memory for no specific reason. The result is that you are suddenly not able anymore to install your security policy. You will face the error shown in the title. In the SmartView Tracker you get an log entry saying "TCP packet out of state, first packet isn't SYN". The SmartView Status shows the firewall module as disconnected. You need to reboot your firewall node for solving this problem. Depending on your hardware you may face the problem again within 12 hours up to 1 week. The firewall still works nicely even with that problem.


casmith32 writes:
I had a very similar situation. My problem was that for some reason, my firewall was NATing return packets back to my mgmt server, which is on a valid IP address. Basically I have a network being HideNAT'd to an external address, with the internal IF of the firewall being on an invalid network which is also routed between the valid network where my mgmt server lies, via an internal router. All comms back to the mgmt server via the Internal IF were getting nat'd because the internal IF was encompassed by the network objects HideNAT setting.

Now you'd think the firewall would know that it shouldn't nat it's own interface...especially when it's the source of the traffic. The only way I got to fix it was to change my HideNAT from a virtual address to hiding behind the firewall's external IF. Go figure... but it works!!


namorcram writes:
I solved this exact same problem in a similar way; I was trying to connect to several Splat boxes over the Internet and couldn't do so (same error message as posted here) until I assigned a Static NAT public address to my mgmt server object. Everything works fine now.

-- PhoneBoy - 04 Jan 2004


Kastus writes:
In my case cpd daemon was dead. Restarting it with $CPDIR/bin/cpd & was enough to fix the problem. For the record: it is SecurePlatform R55 with HFA_R55_04

-- KastusShchuka - 08 Jul 2004


FAQForm
FAQs.Class: TroubleshootingFAQs
FAQs.OS: OsSecurePlatform
FAQs.Version:

rrico
2005-08-22, 12:06
Just for the records, I got the same problem and the reason was not enough space in the management-console local hard drive.

cpsundar
2009-01-06, 09:25
Hi All,

I ran into the same problem with a NGX R65 - Cluster XL. Whenever I try to push a policy I get this error. can some one please give some inputs on this.

Installation Targets Version Policy Type Details
swcpcl NGX R65 Advanced Security Installation failed. Reason: TCP connectivity failure ( port = 18191 )( IP = 10.168.125.2 )[ error no. 10 ]. ( message from member swfw1 )

Setup:
------

DMZ---->10.168.125.x---MM---->FW1/FW2(Cluster XL)----->Internet

Please let me know, if you need any more inputs.

Thanks
CPS