PDA

View Full Version : All Objects and Categories disappeared from Objects tab



tmatuschak
2017-11-16, 17:10
Hello all,

So we had an issue where an object got seemingly "stuck" in our SmartConsole (R80) and would not delete without crashing.

In this case, we went ahead and did a restore from a backup taken this morning before any editing had happened.

What we've ended up with is frightening - all objects and categories under the Objects tab are completely gone.

The rules and etc. still have the correct objects associated with them, so I'm suspecting a database issue. Also, when I go to install database, 3 Smart1 objects with the same name and IP address now show up instead of one.


Does anyone have any good ideas, aside from contacting support?

EricAnderson
2017-11-16, 18:26
I have come across cases of R80.x database "corruption". In one memorable instance, any click to enable "HTTPS Inspection" on any gateway would crash SmartConsole.

One possible workaround (which was the "solution" ion the aforementioned case) is to run an export and re-import. TAC may tell you to export, re-build, and then import, but conceptually, re-importing will overwrite like objects and potentially correct anomalies.

Just to clarify, I'm referring to "migrate export filename" and then "migrate import filename".

Just one relatively painless process that's worth a shot.

-E

EricAnderson
2017-11-16, 18:28
Upon further reflection, I'd definitely give this a shot. If there had been corruption prior to the backup, the corruption would be included in the backup and restore. Export/import does more of a "rebuild".

-E

tmatuschak
2017-11-17, 10:11
No luck on that one, but it was a painless process.

Still the same situation at the moment.

EricAnderson
2017-11-17, 13:15
Since we're stuck anyway, and have a backup (sort of), how about just deleting the offending object it with GUIdbedit? Still works in R80.x as well.

-E

PhoneBoy
2017-11-19, 14:53
I'd strongly encourage getting the Check Point TAC involved here.

tmatuschak
2017-11-20, 14:48
I worked with TAC over the weekend and we've got a solution.

In general, this happens to be a problem in R80 and is fixed and/or better in R80.10.

We were given a custom script (not web-available) that ran and deleted the duplicate objects, leaving us with the originals.


Thanks for the thoughts on this, regardless. I'm a little new to the Checkpoint world so any help is always appreciated.