PDA

View Full Version : Time running out of sync.



vincent.tai
2015-02-06, 05:12
I have a pair of SG4400 running ClusterXL but I noticed the time is running out of sync even I have enable NTP.

[Expert@FW]# clock
Fri Feb 6 16:49:15 2015 -0.153869 seconds ***this time is out. The current time is 17:08

[Expert@FW]# uptime
17:08:07 up 208 days, 3:20, 1 user, load average: 0.05, 0.02, 0.00 ***the time show at uptime is correct

Messages at var/log show that my NTP is working and adjusting their time. I really have no clue what happen...

[Expert@FW]# more messages
Feb 6 16:55:48 2015 MBBSINFG3PROD01 ntpdate[30396]: adjust time server 10.88.2.50 offset 0.000094 sec
Feb 6 16:55:50 2015 MBBSINFG3PROD01 ntpdate[30398]: adjust time server 10.88.2.50 offset 0.000093 sec
Feb 6 16:55:52 2015 MBBSINFG3PROD01 ntpdate[30400]: adjust time server 10.88.2.50 offset 0.000023 sec

cciesec2006
2015-02-06, 06:16
I have a pair of SG4400 running ClusterXL but I noticed the time is running out of sync even I have enable NTP.

[Expert@FW]# clock
Fri Feb 6 16:49:15 2015 -0.153869 seconds ***this time is out. The current time is 17:08

[Expert@FW]# uptime
17:08:07 up 208 days, 3:20, 1 user, load average: 0.05, 0.02, 0.00 ***the time show at uptime is correct

Messages at var/log show that my NTP is working and adjusting their time. I really have no clue what happen...

[Expert@FW]# more messages
Feb 6 16:55:48 2015 MBBSINFG3PROD01 ntpdate[30396]: adjust time server 10.88.2.50 offset 0.000094 sec
Feb 6 16:55:50 2015 MBBSINFG3PROD01 ntpdate[30398]: adjust time server 10.88.2.50 offset 0.000093 sec
Feb 6 16:55:52 2015 MBBSINFG3PROD01 ntpdate[30400]: adjust time server 10.88.2.50 offset 0.000023 sec


try this:

1- remove NTP server IP address from the NTP section,
2- run "ntpdate 10.88.2.50" about 5 times,
3- run "clock --systohc" to set the hardware clock to be the same as your system clock,
4- now put NTP server ip address back into the NTP section

vincent.tai
2015-02-09, 02:35
try this:

1- remove NTP server IP address from the NTP section,
2- run "ntpdate 10.88.2.50" about 5 times,
3- run "clock --systohc" to set the hardware clock to be the same as your system clock,
4- now put NTP server ip address back into the NTP section

Got the below error when running ntpdate:

[Expert@FW]# ntpdate 10.88.2.50
9 Feb 14:34:12 ntpdate[7533]: no server suitable for synchronization found

cciesec2006
2015-02-09, 07:20
Got the below error when running ntpdate:

[Expert@FW]# ntpdate 10.88.2.50
9 Feb 14:34:12 ntpdate[7533]: no server suitable for synchronization found

this is what I did

1- when I still have NTP server setting in the configuration:
cpfw> show configuration ntp
set ntp active on
set ntp server primary 4.2.2.1 version 4
set ntp server secondary 4.2.2.2 version 4
cpfw>
When I run the command, I get error, which is expected
[Expert@cpfw]# ntpdate 4.2.2.2
9 Feb 11:12:14 ntpdate[6475]: the NTP socket is in use, exiting


2- Now when I turned OFF NTP server
set ntp active off
When I run the same command, it works as expected:
[Expert@cpfw]# ntpdate 4.2.2.2
9 Feb 11:14:09 ntpdate[9972]: step time server 4.2.2.2 offset 0.599505 sec
[Expert@cpfw]# clock --systohc
[Expert@cpfw]# clock
Mon Feb 9 11:17:45 2015 -0.000215 seconds
[Expert@cpfw]#

this is just standard Linux,

[Expert@cpfw]# ntpdate 8.8.8.8
9 Feb 11:19:16 ntpdate[11422]: no server suitable for synchronization found
[Expert@cpfw]#

Now 8.8.8.8 does not work because it is not a NTP server, it is Google DNS server.