PDA

View Full Version : R75.40VS gaia upgrade and restore problem



eduardw
2012-11-13, 10:39
Hi All

We are planning a upgrade of our R75.10 MDM tot R75.40VS gaia.
But we run in to a problem.
We build a copy of our production mdm server and did a inplace upgrade to gaia R75.40VS this went without any problems.

But after the upgrade when we did a mds export an than tried to restore the mds to a clean R75.40VS gaia intstall it won’t work.
We also tried to use the export tools on dvd to export our current r75.10 mdm and then import it on the fresh installed R75.40VS gaia (on open server). Also tried it with the management server migration tools without any luck.

Any suggestion how to get this working.
We need to get this working so we can start with a clean installed box

Update
We may have found the problem (we did not read the installation and upgrade guide correct) 
We are now trying the upgrade as followed. We mount the R75.40vs gaia dvd and then uninstallscript and then the export options(on our R75.10 production mdm). After we copy the export to the clean install and try the mds_import
I will let you know if this works (will take some time 1or2 days)

Eduard

eduardw
2012-11-15, 18:03
Too bad we did not get it to work.

We now switch back to R75.40vs splat. This worked without any problems.

We run the export script on our R75.10 MDM and imported the files on our fresh installed R75.40VS Splat server.
To bad that this not work for the gaia version.
We will now test this on our R75.10 MLM.
After that we will start with some more testing like vsx_util to rebuild one of our vsx nodes.
First test a few weeks ago with the vsx_util failed. After in place upgrade we run the vsx_util reconfigure.
The vsx node was rebuild fine but with no policy all virtual systems had their initial policy we could push them and then the virtual system gets his policy. Also we noticed when we push serveral virtual systems from newly created MDM and then do a vsx_util reconfigure only the recently pushed firewalls had their policy all other virtual system had an initial policy


Eduard

UpIrons
2013-01-31, 11:41
Just a thought but have you checked your gtar version in /opt/CPshrd-R75x/util folder?

Check it by going to that folder and typing:

./gtar --version

and it will tell you which version is running. You will likely need to make a backup of the version if it is anything less than 1.26 and then install gtar-1.26 and ensure that it is in that directory specifically.

I just upgraded from R70 to R75.40 Provider-1 (not directly, had to go to R75 base in between) and found that the only way to get the export/import to work properly is by using gtar-1.26 and it MUST be in that folder above.

Then once you're all done, change back to the original gtar version in that folder because otherwise, hotfixes will not run properly.

This was on Solaris 10 though, so YMMV.

eduardw
2013-03-03, 11:11
Follow up.

Later we found and sk with the solution (have to manual ad version in text file, cannot find the sk now) but by that time we all ready went for the R75.40VS splat solution.
It took us a while (limited time to do the preparation). In the First week of February We’ve upgrade our management environment.
And now we get a lot of policy installation errors (vsx R65 clusters), also we are able to push the policy to one of the cluster nodes even when we marked that policy installation is only possible if both members succeed.
We are probably have to open another service request.

Eduard