PDA

View Full Version : PluginPackCompatibilityChecker' failed



checkpointfan
2012-06-21, 22:08
I am attempting to build a new Security Managment server from R71.30 on Windows to R75.40 on a VM with GAIA. The migrate export was sucessful, however when I do a migrate import into the fresh built R75.40, it fails with the below log messages. Any thoughts on how to get rid of the plugins or get around this issue? Any assistance would be appreciated. Thank you!


20 Jun 14:43:32] .--> CanonicalizePath
[20 Jun 14:43:32] [CanonicalizePath] Canonicalizing path '/opt/CPsuite-R75.40/fw 1/bin/upgrade_tools'
[20 Jun 14:43:32] [CanonicalizePath] Resulting path: '/opt/CPsuite-R75.40/fw1/bi n/upgrade_tools/'
[20 Jun 14:43:32] .<-- CanonicalizePath
[20 Jun 14:43:32] .--> PluginPackCompatibilityChecker::GetPluginPackId
[20 Jun 14:43:32] [PluginPackCompatibilityChecker::GetPluginPackId] Reading plug in pack id information file located at '/opt/CPsuite-R75.40/fw1/tmp/migrate//mai n_db/_plugin_upgrade_/plugin_pack.conf'
[20 Jun 14:43:32] ..--> ReadFwsetFile
[20 Jun 14:43:32] ...--> UpgradeMacroReplacer::Instance
[20 Jun 14:43:32] ...<-- UpgradeMacroReplacer::Instance
[20 Jun 14:43:32] [ReadFwsetFile] Going to read file '/opt/CPsuite-R75.40/fw1/tm p/migrate//main_db/_plugin_upgrade_/plugin_pack.conf'
[20 Jun 14:43:32] [ReadFwsetFile] ERR: Failed to open file: No such file or dire ctory
[20 Jun 14:43:32] ..<-- ReadFwsetFile
[20 Jun 14:43:32] [PluginPackCompatibilityChecker::GetPluginPackId] ERR: Failed to read plugin pack id information file
[20 Jun 14:43:32] .<-- PluginPackCompatibilityChecker::GetPluginPackId
[20 Jun 14:43:32] .--> PluginPackCompatibilityChecker::GetPluginPackId
[20 Jun 14:43:32] [PluginPackCompatibilityChecker::GetPluginPackId] Reading plug in pack id information file located at '/opt/CPsuite-R75.40/fw1/bin/upgrade_tool s/plugin_pack.conf'
[20 Jun 14:43:32] ..--> ReadFwsetFile
[20 Jun 14:43:32] ...--> UpgradeMacroReplacer::Instance
[20 Jun 14:43:32] ...<-- UpgradeMacroReplacer::Instance
[20 Jun 14:43:32] [ReadFwsetFile] Going to read file '/opt/CPsuite-R75.40/fw1/bi n/upgrade_tools/plugin_pack.conf'
[20 Jun 14:43:32] [ReadFwsetFile] Succeeded to read file
[20 Jun 14:43:32] ..<-- ReadFwsetFile
[20 Jun 14:43:32] [PluginPackCompatibilityChecker::GetPluginPackId] Plugin pack id is: 'R75.40'
[20 Jun 14:43:32] .<-- PluginPackCompatibilityChecker::GetPluginPackId
[20 Jun 14:43:32] [PluginPackCompatibilityChecker::exec] ERR: Failed to get plug in pack ids for source/destination machines
[20 Jun 14:43:32] <-- PluginPackCompatibilityChecker::exec
[20 Jun 14:43:32] [ActivitiesManager::exec] ERR: Activity 'PluginPackCompatibili tyChecker' failed
[20 Jun 14:43:32] [ActivitiesManager::exec] WRN: Activities execution finished w ith errors
[20 Jun 14:43:32] [ActivitiesManager::exec] WRN: Activities 'PluginPackCompatibi lityChecker' have failed
[20 Jun 14:43:32] [ActivitiesManager::exec] Designated exit code is 1
#

goldberg
2012-06-22, 15:23
Try this:
https://forums.checkpoint.com/forums/message.jspa?messageID=31083

OR

https://www.cpug.org/forums/check-point-secureplatform-splat/9179-new-splat-smartcenter-upgrade_import-fails.html


Let me know if it helps

mguyard
2012-06-25, 03:50
Hi,

This error appear when you don't have do your upgrade export with the destination binary version.
You need to download upgrade tools r75.40 and install this on your management. Make a new "migrate export" on old management and a "migrate import" on the new version.

checkpointfan
2012-06-25, 10:08
Mguyard, thanks for the reply. I should have added in the original post that YES I did download the latest migration tools from the CP site and installed on the source SMS server on R71.30 and used it for the export. The export went well but the import gives the errors indicated. I tried this on 2 VM's, same results.

The CP Gaia docs say you can upgrade from R71.40 and up. I'm on R71.30 but not doing an upgrade, but an export/import. According to a Checkpoint engineer I talked to this should work, but perhaps its too much of a jump..R71.30 to R75.40 GAIA or something between going SMS windows to SMS on Gaia.

Here is some further background from this weekend testing.
I've tried these steps to resolve without success.

1. Created a SMS in VM on R71.30 but on SPLAT(same version) and tried import. Still fails for same reasons.
2. untar export file and modified the configuration and configuration2 file, removing the lines referencing plugin information. tar all the files back up and tried import again. ended with errors. See below.
3. From R71.10 Known Limitations.
When exporting a Security Management server's database that was upgraded with an HFA/minor version from Windows to SecurePlatform/IPSO/Solaris, perform these steps to avoid import failure:
1. cpstop
2. Convert the text file %fwdir%\conf\objects_5_0.C to Unix format (either transfer the file to SecurePlatform/Solaris, run 'dos2unix objects_5_0.C' and transfer the converted file back, or perform the conversion using tools available in Windows).
4. Performed steps outlined in CPUG (Uninstall management plugins) https://forums.checkpoint.com/forums/message.jspa?messageID=31083
5. Performed steps outlined in CPUG (modify config files)
https://www.cpug.org/forums/check-point-secureplatform-splat/9179-new-splat-smartcenter-upgrade_import-fails.html

ShadowPeak.com
2012-06-25, 12:47
Mguyard, thanks for the reply. I should have added in the original post that YES I did download the latest migration tools from the CP site and installed on the source SMS server on R71.30 and used it for the export. The export went well but the import gives the errors indicated. I tried this on 2 VM's, same results.

The CP Gaia docs say you can upgrade from R71.40 and up. I'm on R71.30 but not doing an upgrade, but an export/import. According to a Checkpoint engineer I talked to this should work, but perhaps its too much of a jump..

You say you downloaded the "latest" migration tools and I assume you mean the R71.30 or R71.40 version of those. Upgrading from R71.30 directly to either of these releases is not supported and may well be your issue. Did you try to run the pre_upgrade_verifier before you did the export?

Download the vanilla R75 migration tools ("R75 Management Server migration tools for Windows ") and use them to run the pre_upgrade_verifier and create the export. The built-in version of migrate on the target system should be fine to use for the import.

checkpointfan
2012-06-25, 12:57
Shadowpeak,

Thanks. I used the migration tools for R75.40 and put those on the source SMS running R71.30. Pre_upgrade_verifier failed saying it could not read the objects_5_c file. ran into this before on windows systems and had to skip it.
The CP upgrade map says that R71.30 to R71.40 is a supported migration plan. I am thinking now to try migrating from R71.30(windows) to R71.40(SPLAT) using the R71.40 migration tools and if successful, upgrade to R75.40(GAIA) from there.

Question, for the migration tools when going from Windows to SPLAT. Do you use the migration tools for the OS that is CURRENTLY running , or the migration tools for the OS you want to go to? I believe it is the latter?

Thanks!

ShadowPeak.com
2012-06-25, 13:01
Shadowpeak,

Thanks. I used the migration tools for R75.40 and put those on the source SMS running R71.30. Pre_upgrade_verifier failed saying it could not read the objects_5_c file. ran into this before on windows systems and had to skip it.
The CP upgrade map says that R71.30 to R71.40 is a supported migration plan. I am thinking now to try migrating from R71.30(windows) to R71.40(SPLAT) using the R71.40 migration tools and if successful, upgrade to R75.40(GAIA) from there.

Question, for the migration tools when going from Windows to SPLAT. Do you use the migration tools for the OS that is CURRENTLY running , or the migration tools for the OS you want to go to? I believe it is the latter?

Thanks!

You use the migration tools for the OS you are currently on, and for the Check Point release that you want to go to. Just for grins try the vanilla R75 tools, I've had to use those in certain situations where the latest R75.30/R75.40 migration tools didn't work. You can upgrade directly from just about anything to R75 vanilla.

checkpointfan
2012-06-25, 13:45
I will try this with a slight twist. Checking the Checkpoint upgrade map, R71.30 is the only version that is NOT upgradeable directly to R75. I'll go to R71.40 using the R71.40 upgrade tools. If this works, then there is a supported path to R75.40

sec_guy2011
2012-06-25, 14:48
I will try this with a slight twist. Checking the Checkpoint upgrade map, R71.30 is the only version that is NOT upgradeable directly to R75. I'll go to R71.40 using the R71.40 upgrade tools. If this works, then there is a supported path to R75.40


Hi, in my opinion, if you upgrade this SM to R71.30 version, and then upgrade it from R71.30 directly to R75.40, using the migration tools from this version (R75.40 Management Server Migration Tools), you won't get any problem.

checkpointfan
2012-07-02, 16:33
Problem resolved. Here are the steps takes to resolve this. Found an unsupported CP object and doing a 2 step upgrade worked in my case.

R71.30 to R75,40 migrate is not supported although was told otherwise by CP support and another CP engineer Lesson learned...always follow upgrade map. GAIA being only 3 months new, not alot of exposure as of yet. Running Migrate export will indicate this when ran.
1. I downloaded the R75.20 migration tools for Windows and installed on R71.30 SMS. R71.30 seems unique and limited in the available upgrade paths.
2. Ran pre_upgrade verifier that indicated an unsupported Checkpoint object, an R61 firewall cluster.
3. I changed the OS on this SMS object and re ran verifier. Verified without errors.
4. Ran Migrate export and migrate import into R75.20 using tools installed during R75.20 build of new SMS.
5. Migrate was successful.
6. Upgraded R75.20 SPLAT to R75.30 GAIA without issue.