PDA

View Full Version : SPLAT SCP problem



cozmic
2010-11-24, 11:03
Hi,

I am having issues transferring large files from SPLAT-server running R65 using SCP (tried both winscp/pscp/regular linux scp). It seems that small files are ok. I instantly get this error from winscp: "copying file 'foobar' fatally failed." It seems that the sshd version have some kind of bugg. Can't find any proper logfile on the SPLAT server that explains anything also.

Has anyone else got this error or got any workaround ?

/C

* UPDATE *
Found this solution if anyone experience this:

<snip>
It's a bug in OpenSSH that WinSCP is now triggering... I commented on it here:
http://winscp.net/forum/viewtopic.php?t=8762

Perhaps someone with privileges can add it to the bug tracker?

The workaround is to use version 4.1.9 or switch to sftp mode instead of using scp.
</snip>

lammbo
2010-11-24, 11:08
It seems that small files are ok. I instantly get this error from winscp: "copying file 'foobar' fatally failed."

Use an older version of WinSCP - get 4.1.9 and you'll be fine.

mcnallym
2010-11-24, 14:48
Seems to happen on R70 and R71 as well, not just R65.

Slight problem we have found though is that 4.1.9 doesn't run on our Windows 7 machines.

Will have to see if the use SFTP instead of SCP works for us on the R70 and R71 systems.

melipla
2010-11-29, 17:27
Has anyone else got this error or got any workaround ?


If I scp/sftp from a splat box out to a normal linux box then it works fine so for large files I'm glad the network is fast because I end up copying them twice.

I'm guessing that R75 will fix this problem.

ksamstad
2011-02-23, 08:35
If you are having problems transferring large files, (for example >1MB), use WinSCP 4.2.9 and do the following:

Start new session, click on SSH, Under protocol options, click on "Enable compression"

Then start your session, and you should be fine.

This was tested on WinSCP 4.2.9 and R71.10

klaus
2012-09-06, 09:45
If you are having problems transferring large files, (for example >1MB), use WinSCP 4.2.9 and do the following:

Start new session, click on SSH, Under protocol options, click on "Enable compression"

Then start your session, and you should be fine.

This was tested on WinSCP 4.2.9 and R71.10

It does not work on R75.40 and WinSCP 5.0.6 (build 2074).... I had to FTP the cpinfo out (53M file) in order to sftp it then to Checkpoint.
However, Checkpoint has issued the sk66195, but all it says is that this is a redhat bug (kernel 2.6) and contact support to get a hotfix.

Klaus

RayPesek
2012-09-12, 19:17
Slight problem we have found though is that 4.1.9 doesn't run on our Windows 7 machines.

I'm glad I didn't read this before I installed 4.1.9 on my brand-spanking new 64-bit Windows 7 Enterprise SP1 desktop yesterday. :-)

WinSCP even picked up that it was a 64-bit OS but the installer failed registering one DLL. Something like DragExt64.dll; can't remember right now. I just went into the program folder where the DLL lives and did the "regsvr32 dragext64.dll" and it registered and has been working fine so far.

Ray

peter42
2013-05-14, 07:45
It is fixed in R75.46.

One work around is to switch WinSCP to SCP and uncheck the optimize buffer option.