PDA

View Full Version : Again a problem with revert



eduardw
2009-09-19, 08:54
Hi all
Today I tried to revert one of our VSX r65 cluster nodes.
After giving the revert command using ilo.
The machine reboot and after reboot I only saw
GRUB followed by a flashing cursur. After waiting for more then a hour I did an other reboot with no succes.

Any ideas, other the a clean install.
The cli is ony displaying GRUB I'm not abeble to enter any commands, I only have ilo access.

Kind Regards

eduardw
2009-09-22, 17:13
I "fixed" the problem the hard way.

Because we also had some other problems with the node, I did a clean install followed by vsx_util reconfigure. The node is now working great again.

Checkpoint told me the problem could also be fixed by booting the box from a linux/ubuntu boot cd and then fix the grub boot menu.

To bad that not everything of the node is restored by using the vsx_util.

I hope that checkpoint will enhance this in the future so we can configure dynamic routers from the smart center and also use the smart center to manage the local system user accounts.

And that using the vsx_util then also configures the local users and the dynamic router settings.
I will ask for this in a enhancement request.

eduardw
2009-10-01, 14:54
Yesterday I did a clean build, and after running cpconfig i made a snapshot and tried a revert. And again the system hangs in grub.
Their is definitely some thing wrong with snapshot and revert for vsx r65.

polymath
2010-03-04, 17:46
I'm probably too late for eduardw, but if you run into the same problem "http://www.cpug.org/forums/disaster-recovery/12834-boot-failure-after-revert.html" may help.

eduardw
2010-03-05, 08:39
Polymaht,
Thanks for the reply, Indeed a little bid late.

But after almost 4 month's checkpoint made a patch for us. I installed it a couple of weeks ago.
Snapshot created with this new patch can be reverted without any problems.


Eduard

sisu-up
2010-05-07, 16:18
For what its worth. I just do a clean build, patch, install a lic and run vsx_util reconfigure. Any other configuration is pretty trivial, and any scripts I write go into a separate server under cvs/rcs control.

I do perform backups occasionally but I found snapshot/revert to be so buggy with P1 and VSX that it's useless to me, not to mention the disk space it consumes and moving it off the host for short/long term storage.

I do this in my lab frequently and its a pretty darn useful.

my 2 cents.